粗茶でございます日本語 プログラミング 言語 「なでしこ」 大好き 

このページの記事目次 (カテゴリー: メール送信ツール

total 5 pages  次のページ →  

スポンサーサイト

   ↑  --/--/-- (--)  カテゴリー: スポンサー広告
上記の広告は1ヶ月以上更新のないブログに表示されています。
新しい記事を書く事で広告が消せます。

(記事編集) http://nadesocha.blog.fc2.com/?overture" target="_new

--/--/-- | Comment (-) | ホーム | ↑ ページ先頭へ ↑ |

メール送信プログラムの開発 第21回

   ↑  2006/05/29 (月)  カテゴリー: メール送信ツール

■メール送信之介ver.3.13


 メールを送信することはできましたが、本当に正しく送信できたのか確認できません。
 ひとつの方法として、BCCに自分自身のメールアドレスを設定すると、あとで自分のメールボックスを開いて、送信結果を確認できます。


 もうひとつは、送信した内容をログファイルとして保存する方法です。
 正確にはログファイルだけでは、送信結果を確認するだけで、送信できたかどうかは別の話ですが、少なくとも安心できると思います。


 そこで、今回はメールを送信したあとに、送信内容を表示する機能を作成します。



*** ログファイルの作成 ***
 ログファイルの内容は、以下の通りになります。


   件名:
   {メール件名}
   本文:
   {メール本文}
   CC:
   {メールCC}
   BCC:
   {メールBCC}
   送信先1:
   {メール宛先}
   添付1:
   {メール添付ファイル}
   送信先2:
   {メール宛先}
   添付2:
   {メール添付ファイル}
   送信先3:
   {メール宛先}
   添付3:
   {メール添付ファイル}  (以下略)



 ログファイルを保存するための変数を宣言します。


#List01
#---変数初期化
(中略)
メールログは空



*** ログファイルへ記録 ***
 送信処理をしながら、送信内容をログファイルに記録していきます。
 「●メール連続送信」を次の通りに書き換えます。


#List02
●メール連続送信
  もし(メールホスト=空)または(メールID=空)または(メールパスワード=空)ならば
    「メールアカウントを設定してください。」と言う  #---1
    戻る
  「メールを送信します。{改行}NortonAntiVirusなどのメールチェックは解除してください。」と言う
  メール件名はEd_1
  メール本文はMm_1
  メールCCはCCアドレス
  メールBCCはBCCアドレス
  メールログは「件名:{~}{メール件名}{~}本文:{~}{メール本文}{~}CC:{~}{メールCC}
BCC:{~}{メールBCC}{~}」              #---2
  10回
    メール宛先は送信アドレス[回数]を「;」で区切ったもの
    もしメール宛先が空でなければ
      メール添付ファイルは添付パス[回数]を「;」で区切ったもの
      メール送信
      メールログはメールログ&「送信先{回数}:{~}{メール宛先}{~}添付{回数}:{~}{メール添付ファイル}{~}」
                             #---3
      5秒待つ
  「メール送信完了!」と言う
  メールログを言う                   #---4


1. メールアカウントが設定されていなければ、メール送信をせずに戻ります。
2. メールログに「件名」と「本文」と「CC」「BCC」を記録します。
3. メールログに「送信先」と「添付ファイル」を記録します。
4. 送信が終了したらメールログを表示します。


 表示されたメールログをメモ帳などにコピーして、保存してください。
 送信日時をファイル名として自動保存できるように改良してもいいですね。



*** 終了確認 ***
 母艦の「閉じる」ボタンをクリックした時、メニューの「終了」を選択した時、終了確認をします。
 ユーザーが「いいえ」を選択したら、終了しません。


#List03
●終了確認
  ダイアログタイトルは「終了確認」
  「終了しますか?」と二択
  もしそれがはいならば
    母艦の終了可能ははい      #---1
  違えば
    母艦の終了可能はいいえ


1. 「終了可能」はシステム変数です。値に「はい」を設定するとアプリケーションを終了できますが、「いいえ」を設定するとアプリケーションを終了できません。



ここまでのプログラムは こちらからダウンロードしてください。



※「メニュー一括作成」を修正しました。



 これで、ようやくメール送信プログラムが完成しました!
 もし、バグがありましたら、ご報告ください。
 あと、自由に改造してもっともっと便利なツールにして、私に教えてくださ~い。


 いやぁ、長い道のりだったよ。

スポンサーサイト

(記事編集) http://nadesocha.blog.fc2.com/blog-entry-24.html

2006/05/29 | Comment (0) | Trackback (0) | ホーム | ↑ ページ先頭へ ↑ |

メール送信プログラムの開発 第20回

   ↑  2006/05/28 (日)  カテゴリー: メール送信ツール

■メール送信之介ver.3.12


 何度も同じ内容のメールを送る場合、ひな形があれば便利です
 そこで、テンプレートをファイルとして保存し、呼び出して使えるようにします。


 「メール送信之介」に、テンプレート設定画面を作成します。



*** テンプレート管理画面の作成 ***
 テンプレート管理画面は次の通りです。


s-mail14













#List01
#---テンプレート画面を作成
テンプレート画面とはフォーム
そのタイトルは「テンプレート管理」
その背景色はウィンドウ背景色
そのスタイルはダイアログスタイル
そのクライアント幅は320
そのクライアント高さは240
その閉じた時は~母艦の有効はオン
Lb_20とはラベル
その親部品はテンプレート画面
そのテキストは「件名:」
その位置は「5,5」
Cb_5とはコンボ
その親部品はテンプレート画面
そのサイズは「5,20,315,30」
その編集はオフ
その変更した時は~テンプレート開く
Lb_21とはラベル
その親部品はテンプレート画面
そのテキストは「本文:」
その位置は「5,50」
Mm_2とはメモ
その親部品はテンプレート画面
そのサイズは「5,65,315,205」
Bt_29とはボタン
その親部品はテンプレート画面
そのサイズは「5,210,60,235」
そのテキストは「新規」
そのクリックした時は~テンプレート新規
Bt_30とはボタン
その親部品はテンプレート画面
そのサイズは「65,210,120,235」
そのテキストは「取込」
そのクリックした時は~テンプレート取込
Bt_31とはボタン
その親部品はテンプレート画面
そのサイズは「125,210,180,235」
そのテキストは「削除」
そのクリックした時は~テンプレート削除
Bt_32とはボタン
その親部品はテンプレート画面
そのサイズは「185,210,240,235」
そのテキストは「更新」
そのクリックした時は~テンプレート更新
Bt_33とはボタン
その親部品はテンプレート画面
そのサイズは「260,210,315,235」
そのテキストは「設定」
そのクリックした時は~テンプレート設定



 件名がそのままファイル名で検索できるように[部品]コンボボックスを配置し、本文を編集できる[部品]メモを使います。



*** イベントの処理 ***
 テンプレート管理画面編集について、必要なイベントは次の通りです。
・テンプレート編集画面を呼び出します。
・以前作成したテンプレートファイルを開きます。
・新規にテンプレートファイルを作成します。
・編集したテンプレートをファイルに保存します。
・メイン(母艦)に入力した本文をテンプレートにします。
・テンプレートファイルを削除します。



*** 編集画面を呼び出す ***
 母艦(メイン画面)のメニューから呼び出します。


#List02
●テンプレート呼出
  母艦の有効はオフ        #---1
  テンプレート画面の可視はオン  #---2
  テンプレート初期        #---3


1. テンプレート画面を操作中は母艦を操作できないようにします。
2. テンプレート画面を表示します。
3. テンプレート初期に進みます。



*** テンプレートファイルを探す ***
 プログラムと同じフォルダにある、テンプレートファイルを探して、[コンボ部品]Cb_5に表示します。


#List03
●テンプレート初期
  F_NameはCb_5のテキスト     #---1
  「*.tpf」のファイル列挙     #---2
  Cb_5のアイテムはそれ      #---3
  ItemはCb_5のアイテム      #---4
  Itemの0からF_Nameを配列検索   #---5
  Cb_5の値はそれ         #---6
  もしF_Nameが空ならば      #---7
    Mm_2のテキストは「」    #---8


1. [コンボ部品]Cb_5で選択されているファイル名を[文字列変数]F_Nameに代入します。
2. 実行プログラム(母艦)と同じフォルダの中から、拡張子が「tpf」のアカウントファイルを探します。その結果(ファイル名のリスト)を[特殊変数]「それ」に格納します。
3.[特殊変数]「それ」に格納された、アカウントファイルのファイル名リストを、[コンボ部品]Cb_5に表示します。
4. さきほどCb_5に格納したファイル名リストを[一時変数]Itemに代入します。
5. [一時変数]Itemの中から[文字列変数]F_Nameに一致するデータを探して、その位置を[特殊変数]「それ」に格納します。
6. [コンボ部品]Cb_5の値を、そのファイル名にします。
7. もし[コンボ部品]Cb_5で何も選択されていなければ、本文がありませんので、#8の処理を実行します。
8. [メモ部品]Mm_2のテキストをクリアします。



*** テンプレートファイルを開く ***
 [コンボ部品]Cb_5でファイルを選択すると、その内容を[メモ部品]Mm_2に表示します。


#List04
●テンプレート開く
  Cb_5のテキストを開く    #---1
  Mm_2のテキストはそれ    #---2


1. [コンボ部品]Cb_5に表示されているファイルを開き、その内容を[特殊変数]「それ」に代入します。
2. [特殊変数]「それ」の内容を[メモ部品]Mm_2に表示します。



*** テンプレートファイルを新規に作成する ***
 「新規」ボタンをクリックすると、新たなテンプレートファイルを作成できます。


#List05
●テンプレート新規
  F_Nameは空
  入力データは空
  ダイアログタイトルは「テンプレート新規作成」
  「新規に作成するテンプレートの件名を{改行}入力してください。」と尋ねる
                  #---1
  F_Nameはそれ
  もしF_Nameが「」ならば戻る
  ファイル名チェック       #---2
  もし判定が「NG」ならば戻る
  F_NameはF_Name&「.tpf」     #---3
  Mm_2のテキストをF_Nameに保存  #---4
  「*.tpf」のファイル列挙
  Cb_5のアイテムはそれ      #---5
  ItemはCb_5のアイテム
  Itemの0からF_Nameを配列検索
  Cb_5の値はそれ


1. ファイル名の入力をします。件名がそのままファイル名になります。
2. 入力されたファイル名が正しいかチェックします。
3. ファイル名に拡張子「.tpf」をつけます。
4. [メモ部品]Mm_2に入力されている内容を、F_Nameのファイル名で保存します。これで新規ファイルが出来上がりました。
5. 新たにファイルが追加されたので、[コンボ部品]Cb_5の内容を変更します。



*** テンプレートに取り込む ***
 母艦の[メモ部品]Mm_2(本文)に入力したデータをテンプレートにします。


#List06
●テンプレート取込
  もし(Mm_1のテキスト)=「」ならば戻る  #---1
  Mm_2のテキストはMm_1のテキスト     #---2


1. 母艦の本文に何も入力されていなければ、以下の処理をしないで戻ります。
2. 母艦の本文データをテンプレートに表示します。



*** テンプレートを設定する ***
 テンプレートファイルの内容をメイン画面(母艦)に設定します。


#List07
●テンプレート設定
  Mm_1のテキストはMm_2のテキスト     #---1
  Cb_5のテキストから4文字右端削除してF_Nameに代入
                      #---2
  Ed_1のテキストはF_Name         #---3
  テンプレート画面を閉じる        #---4


1. [メモ部品]Mm_2の内容を、メイン画面(母艦)の本文に設定します。
2. [コンボ部品]Cb_5のテキストから拡張子を削除します。
  なでしこでは、「~して~する」という具合に、命令を続けて記述できます。
3. メイン画面(母艦)の件名にファイル名を表示します。
4. テンプレート画面を閉じて母艦を表示します。



*** テンプレートを保存します ***
 「更新」ボタンをクリックすると、編集したテンプレートデータを保存します。


#List08
●テンプレート更新
  もしCb_5のテキストが空ならば戻る
  F_NameはCb_5のテキスト
  Mm_2のテキストをF_Nameに保存



*** テンプレートファイルを削除する ***
 テンプレートファイルそのものを削除してしまいます。


#List09
●テンプレート削除
  もしCb_5のテキストが空ならば戻る
  F_NameはCb_5のテキスト
  「{F_Name}を削除します。よろしいですか。」と二択
  もしそれがいいえならば戻る
  F_Nameをファイル削除
  テンプレート初期
  Mm_2のテキストは「」


 ファイル名が選択されていなければ処理を行いません。
 削除の確認をして、ファイルを削除したらファイル名リストを更新して、[メモ部品]Mm_2(本文)の表示をクリアします。



*** メニューの変更 ***
 メニューの設定を次の通り変更します。


#List10
『#親部品名,部品名,テキスト,ショートカット,オプション,イベント
なし,m_file,ファイル(&F),,,
-,m_send,送信(&S),,,メール連続送信
-,-,,,,
-,m_exit,終了(&X),,,終了確認
なし,m_adr,アドレス帳(&A),,,アドレス帳呼出
なし,m_acc,アカウント(&U),,,アカウント呼出
なし,m_tpl,テンプレート(&T),,,テンプレート呼出
』をメニュー一括作成


 


ここまでのプログラムは こちらからダウンロードしてください。


▼次回はログファイルの作成です。

(記事編集) http://nadesocha.blog.fc2.com/blog-entry-23.html

2006/05/28 | Comment (0) | Trackback (0) | ホーム | ↑ ページ先頭へ ↑ |

メール送信プログラムの開発 第19回

   ↑  2006/03/05 (日)  カテゴリー: メール送信ツール

■メール送信之介ver.3.11


 ずいぶんとお休みしてしまいました。
 かれこれ2ヶ月以上も間があいてしまってますね。


 第18回では、「なでしこ」のメール送信について不具合があることを書いていましたが、クジラさんにお願いして修正してもらいましたので、開発を再開できるようになりました。


 なお、開発スケジュールは次の通りに変更します。
 「なでしこ版 メール送信之介」の開発
 「シミュレーションゲーム」の開発


 「ひまわり版 メール送信之介」は、もう使わないので改善しないで放置です。



 では、第16回からの続きを再開しましょう!



 今回はアカウントの設定部分をつくっていきます。


 「メール送信之介」を複数のアカウントで使用できるように、アカウント設定ファイルを作成し、切り替えるための画面を作成します。


・・・と言っても、ほとんどアドレス帳管理画面と同じですので、簡単に説明します。



*** アカウント管理画面の作成 ***
 アカウント管理画面は次の通りです。


s-mail13












#List01

#---アカウント画面を作成
アカウント画面とはフォーム
そのタイトルは「アカウント管理」
その背景色はウィンドウ背景色
そのスタイルはダイアログスタイル
そのクライアント幅は320
そのクライアント高さは240
その閉じた時は~母艦の有効はオン
Lb_19とはラベル
その親部品はアカウント画面
そのテキストは「アカウントファイル:」
その位置は「5,8」
Cb_4とはコンボ
その親部品はアカウント画面
そのサイズは「125,5,285,25」
その編集はオフ
その変更した時は~アカウント開く
Gr_2とはグリッド
その親部品はアカウント画面
そのサイズは「5,30,315,205」
その編集はオン
その行選択はオフ
その自動ソートはオフ
Bt_26とはボタン
その親部品はアカウント画面
そのサイズは「15,210,80,235」
そのテキストは「新規作成」
そのクリックした時は~アカウント新規
Bt_27とはボタン
その親部品はアカウント画面
そのサイズは「85,210,180,235」
そのテキストは「アカウント削除」
そのクリックした時は~アカウント削除
Bt_28とはボタン
その親部品はアカウント画面
そのサイズは「265,210,310,235」
そのテキストは「更新」
そのクリックした時は~アカウント保存



 アドレス管理画面と同様に、グリッドを使用して、表をセル単位で編集できるようにし、アイテムが自動ソートされないようにします。



*** イベントの処理 ***
 アカウント管理画面編集について、必要なイベントは次の通りです。
・アカウント編集画面を呼び出します。
・以前作成したアカウントファイルを開きます。
・新規にアカウントファイルを作成します。
・アカウントファイルに編集内容を保存します。
・アカウントファイルを削除します。



*** 編集画面を呼び出す ***
 母艦(メイン画面)のメニューから呼び出します。


#List02
●アカウント呼出
  母艦の有効はオフ
  アカウント画面の可視はオン
  アカウント初期



*** アカウントファイルを探す ***
 プログラムと同じフォルダにある、アカウントファイルを探して、[コンボ部品]Cb_4に表示します。


#List03
●アカウント初期
  F_NameはCb_4のテキスト        #---1
  「*.acc」のファイル列挙        #---2
  Cb_4のアイテムはそれ         #---3
  ItemはCb_4のアイテム         #---4
  Itemの0からF_Nameを配列検索      #---5
  Cb_4の値はそれ            #---6
  もしF_Nameが空ならば         #---7
    Gr_2のアイテムは「項目,設定値」  #---8


1. [コンボ部品]Cb_4で選択されているファイル名を[文字列変数]F_Nameに代入します。
2. 実行プログラム(母艦)と同じフォルダの中から、拡張子が「acc」のアカウントファイルを探します。その結果(ファイル名のリスト)を[特殊変数]「それ」に格納します。
3.[特殊変数]「それ」に格納された、アカウントファイルのファイル名リストを、[コンボ部品]Cb_4に表示します。
4. さきほどCb_4に格納したファイル名リストを[一時変数]Itemに代入します。
5. [一時変数]Itemの中から[文字列変数]F_Nameを探して、その位置を[特殊変数]「それ」に格納します。
6. [コンボ部品]Cb_4の値を、そのファイル名にします。
7. もし[コンボ部品]Cb_4で何も選択されていなければ、グリッドに表示するものがありませんので、#8の処理を実行します。
8. [グリッド部品]Gr_2に「項目,設定値」を表示します。



*** アカウントファイルを開く ***
 [コンボ部品]Cb_4でファイルを選択すると、その内容を[グリッド部品]Gr_2に表示します。


#List04
●アカウント開く
  Cb_4のテキストを開く
  Gr_2のアイテムはそれ



*** アカウントファイルを新規に作成する ***
 「新規作成」ボタンをクリックすると、新たなアカウントファイルを作成できます。


#List05
●アカウント新規
  F_Nameは空
  入力データは空
  ダイアログタイトルは「アカウント新規作成」
  「新規に作成するアカウントのファイル名を{改行}入力してください。(拡張子.accは不要)」と尋ねる                      #---1
  F_Nameはそれ
  もしF_Nameが「」ならば戻る
  ファイル名チェック                    #---2
  もし判定が「NG」ならば戻る
  F_NameはF_Name&「.acc」
  「項目,設定値」をF_Nameに保存              #---3
  「*.acc」のファイル列挙
  Cb_4のアイテムはそれ                   #---4
  ItemはCb_4のアイテム
  Itemの0からF_Nameを配列検索
  Cb_4の値はそれ
  ダイアログタイトルは「アカウントの作成」
  「送信元アドレス={改行}送信者名={改行}メールホスト(SMTP)={改行}メールID={改行}パスワード={改行}メールオプション=」を項目記入     #---5
  入力データはそれ
  もし入力データが「」ならば戻る
  「{入力データ}{改行}間違いありませんか?」と二択     #---6
  もしそれがいいえならば戻る
  入力データ[0]の1から8文字削除              #---7
  入力データ[1]の1から5文字削除
  入力データ[2]の1から13文字削除
  入力データ[3]の1から6文字削除
  入力データ[4]の1から6文字削除
  入力データ[5]の1から9文字削除
  Gr_2のアイテムは「項目,設定値{改行}送信元アドレス,{入力データ[0]}{改行}送信者名,{入力データ[1]}{改行}メールホスト,{入力データ[2]}{改行}メールID,{入力データ[3]}{改行}パスワード,{入力データ[4]}{改行}メールオプション,{入力データ[5]}」
  アカウント設定                      #---8
  「入力されたアカウントに、テストメールを送信します。{改行}受信できない場合は、アカウントを設定しなおしてください」と言う
  メール宛先は入力データ[0]
  メール件名は「テストメール」
  メール本文は「おめでとう{改行}アカウントは正しく設定されました」
  メール送信                        #---9
  アカウントファイルはF_Name
  (Gr_2のアイテム)をアカウントファイルへ保存        #---10


1. ファイル名の入力をします。
s-mail10





2. 入力されたファイル名が正しいかチェックします。
3. 文字列「項目,設定値」を、F_Nameのファイル名で保存します。これで新規ファイルが出来上がりました。
4. 新たにファイルが追加されたので、[コンボ部品]Cb_4の内容を変更します。
5. 各設定値の入力に「項目記入」を使います。
s-mail11








6. 入力されたデータを確認します。
s-mail12








7. 項目記入すると、項目名=入力値の形でデータが保存されますので、項目名の部分を削除します。
8. メールアカウントに入力した値を設定します。
9. 入力したメールアドレスにテストメールを送信します。正しく送信できなければ、入力した値が間違っていたことになります。
10.入力した設定データをアカウントファイルに保存します。



*** アカウントを設定する ***
 アカウントファイルの内容でメールアカウントを設定します。


#List06
●アカウント設定
  ItemはGr_2のアイテム
  メール差出人は「{Item[2,1]}<{Item[1,1]}>」
  メールホストはItem[3,1]
  メールIDはItem[4,1]
  メールパスワードはItem[5,1]
  メールオプションはItem[6,1]



*** アカウントファイルを保存します ***
 「更新」ボタンをクリックすると、編集したアカウントデータを保存して、アカウント管理画面を閉じます。


#List07
●アカウント保存
  もしCb_4のテキストが空でなければ
    F_NameはCb_4のテキスト
    Itemは空。DataはGr_2のアイテム
    7回
      Item[回数-1]はData[回数-1]
    Item[0]は「項目,設定値」
    ItemをF_Nameに保存
    アカウント開く
    アカウント設定
  アカウント画面を閉じる



*** アカウントファイルを削除する ***
 アカウントファイルそのものを削除してしまいます。


#List08
●アカウント削除
  もしCb_4のテキストが空ならば戻る
  F_NameはCb_4のテキスト
  「{F_Name}を削除します。よろしいですか。」と二択
  もしそれがいいえならば戻る
  F_Nameをファイル削除
  アカウント初期
  Gr_2のアイテムは「」


 ファイル名が選択されていなければ処理を行いません。
 削除の確認をして、ファイルを削除したらファイル名リストを更新して、グリッドの表示をクリアします。



*** メニューの変更 ***
 アドレス帳管理と同じく、アカウント管理もひとつのフォームでできるようになりましたので、メニュー項目の「アカウント編集」と「アカウント削除」が不要になってしまいました。
 そこで、メニューの設定を次の通り変更します。


#List09
『#親部品名,部品名,テキスト,ショートカット,オプション,イベント
なし,m_file,ファイル(&F),,,
-,m_send,送信(&S),,,メール連続送信
-,-,,,,
-,m_exit,終了(&X),,,終了確認
なし,m_adr,アドレス帳(&A),,,アドレス帳呼出
なし,m_acc,アカウント(&U),,,アカウント呼出
なし,m_tpl,テンプレート(&T),,,
-,m_tpl_r,テンプレート呼出(&R),,,テンプレート呼出
-,m_tpl_s,テンプレート保存(&S),,,テンプレート保存
-,m_tpl_e,テンプレート編集(&E),,,テンプレート編集
-,m_tpl_d,テンプレート削除(&D),,,テンプレート削除
』をメニュー一括作成


 たぶん、テンプレート管理も同様にメニュー変更しなければならないと思います。



ここまでのプログラムは こちらからダウンロードしてください。


▼次回はテンプレートの編集に進みます。応援してください!!

(記事編集) http://nadesocha.blog.fc2.com/blog-entry-22.html

2006/03/05 | Comment (0) | Trackback (0) | ホーム | ↑ ページ先頭へ ↑ |

メール送信プログラムの開発 第18回

   ↑  2005/12/27 (火)  カテゴリー: メール送信ツール

■メール送信之介ver.3.10

 メールを送信すると、添付ファイルに変なもの(htmlファイル)がくっついてしまう現象について、これまでに判明したこと。


●現象:
 添付ファイル付のメールを送信すると、その添付ファイルとは別に「ATT00018.htm(58B)」などのhtmlファイルが勝手に添付されてしまう。
 そのhtmlファイルを開いても中身は表示されない。

●検証:
 次の環境で現象が発生するかどうか、メールを送受信してみました。

 「送信側」
  A:NEC製自社サーバー
    Windows2000
  B:一般プロバイダのサーバー
    WindowsXPpro

 「受信側」
  1:NEC製自社サーバー
    Windows2000
    Outlook2002
  2:NEC製自社サーバー
    Windows2000
    Becky!ver.2
  3:一般プロバイダのサーバー
    WindowsXPpro
    ShurikenPro3
  4:一般プロバイダのサーバー
    WindowsXPpro
    Becky!ver.2
  5:Yahoo!メール、Exciteメール、MSN(hot)メール、
    Livedoorメールなどのフリーメール

 「送受信結果」
 A→1:発生した
 A→2:発生した
 A→3:発生した
 A→4:発生した
 A→5:発生しなかった
 B→1:発生した
 B→2:発生した
 B→3:発生しなかった
 B→4:発生しなかった
 B→5:発生しなかった

●結果:
 自社サーバー、Windows2000の組合わせで、現象の再現を確認できました。どちらか(または組合わせ)が原因だと思われます。
 しかし、さらに詳細な原因を追及するには、私の所有するマシンでは限界がありますので、どなたか検証していただけると有難いのですが。ご協力お願いします。

 組合わせによって不具合が発生することがわかりましたので、続けてメール送信プログラムを開発していこうと思います。
 でも、「ひまわり」では、このような現象は発生しなかったので、実際の業務には、ひまわりバージョンを使用することになると思います。

 今後の開発スケジュールは、
 「なでしこ」でメール送信プログラムの開発(本プログラム)
 「ひまわり」でメール送信プログラムの改善
 の順番で行きたいと思います。

(記事編集) http://nadesocha.blog.fc2.com/blog-entry-21.html

2005/12/27 | Comment (0) | Trackback (0) | ホーム | ↑ ページ先頭へ ↑ |

メール送信プログラムの開発 第17回

   ↑  2005/12/14 (水)  カテゴリー: メール送信ツール

■メール送信之介ver.3.10

 ここまで作成してきた時点で、一度実行ファイル(exe)にしてみました。そして実行してみると。。。

 メールと添付ファイルがきちんと送信されました


 しかし。。。

 添付ファイルに変なものがくっついています。送信設定した添付ファイルの他に、全く意図していないファイルも一緒に送信されてしまいました。

 その変なファイルは、A123456.htm。サイズが0バイトのHTMLファイルです。もちろんそのファイルを開いても何も表示されません。

 ファイルを送信するたびに、そのHTMLのファイル名は変わり、そんなファイルはパソコンのどこにも存在しません。

 どうして、意図しないファイルが勝手に添付されてしまうのか、謎です。しばらく現象の再現と原因の究明にとりかかります。

(記事編集) http://nadesocha.blog.fc2.com/blog-entry-19.html

2005/12/14 | Comment (0) | Trackback (0) | ホーム | ↑ ページ先頭へ ↑ |
上記広告は1ヶ月以上更新のないブログに表示されています。新しい記事を書くことで広告を消せます。