粗茶でございます日本語 プログラミング 言語 「なでしこ」 大好き 

このページの記事目次 (tag: サンプル の検索結果)

スポンサーサイト

   ↑  --/--/-- (--)  カテゴリー: スポンサー広告
上記の広告は1ヶ月以上更新のないブログに表示されています。
新しい記事を書く事で広告が消せます。

(記事編集) http://nadesocha.blog.fc2.com/?overture" target="_new

--/--/-- | Comment (-) | ホーム | ↑ ページ先頭へ ↑ |

Kindle版なでしこユーザーズ・マニュアルvol.1が第2版になりました。

   ↑  2013/05/16 (木)  カテゴリー: なでしこ全般
 日本語プログラミング言語「なでしこ」の電子マニュアル日本語プログラミング言語「なでしこ」ユーザーズ・マニュアルvol.1をAmazonKindleにて販売中ですが、このたび第2版にアップデートしました!

 すでに購入いただいている方は、MyKindleからアップデートすることができますので、ぜひ更新してみてください。

 第2版の大きな変更点は、書籍(ファイル)の形式が画像形式からePub形式となったことです。これにより、端末の画面サイズに左右されず、自由なサイズで読むことが可能となりました。


 前記事
スポンサーサイト

この記事に含まれるtag : サンプル マニュアル 

FC2スレッドテーマ : プログラミング (ジャンル : コンピュータ

(記事編集) http://nadesocha.blog.fc2.com/blog-entry-167.html

2013/05/16 | Comment (0) | Trackback (0) | ホーム | ↑ ページ先頭へ ↑ |

Kindle版なでしこマニュアル発売中!

   ↑  2012/12/08 (土)  カテゴリー: なでしこ全般
 2008年に自費出版したユーザー本が、電子書籍としてAmazonで販売開始しました! 書籍版はすでに入手不可能ですので、絶版のない電子書籍をご利用できるようにしました。価格は800円と格安になっていますので、書籍版を購入されていない方だけでなく、すでに書籍版をご購入いただいた方でも、モバイル用としてお手元に置かれるのもいかがでしょうか。

 電子書籍は、2008年時点の情報のために現在の内容とは合わない部分があったりしますが、全体としてはとても充実していますので、是非ご活用ください。

日本語プログラミング言語「なでしこ」ユーザーズ・マニュアルvol.1日本語プログラミング言語「なでしこ」ユーザーズ・マニュアルvol.1
(2012/12/01)
粗茶@なでしこ

商品詳細を見る

「なでしこ入門」
 なでしこのダウンロード・インストールから、プログラミングの基本を紹介。
 プログラミングがはじめてという人のために易しく解説しています。

「ゲームの制作」
 簡単なシューティングゲームを作りながら、ゲームづくりに必要な考え方や基本テクニックを解説。
 有名なTVゲームを作りたいと思ったら、まずこれぐらいは理解できて当然です。

「Word/Excel連携」
 ビジネスで定番となっているエクセルをもっと便利に使いこなすための基本テク。
 なでしこのエクセル関係命令をすべて解説しています。

 Kindleで読むことができます。対応端末またはアプリは次の通りです。
 ・Kindle Paperwhite
 ・Kindle Fire
 ・Kindle for iPad
 ・Kindle for iPod Touch
 ・Kindle for iPhone
 ・Kindle for Android

 端末によっては、文字が読みづらい等の問題がありますので、ご購入前には必ずサンプルをダウンロードして動作確認してくださるようお願いします。

Kindle Fire HD 8.9 32GB タブレットKindle Fire HD 8.9 32GB タブレット
(2013/03/12)
Amazon.co.jp

商品詳細を見る





キーワード はじめて,初心者,学習,基礎,基本,ヘルプ,日本語,プログラミング,プログラム,プログラマ,SE,勉強,ひまわり,なでしこ,C,JAVA,VB,VBA,COBOL,Delphi,CS,JS,IT,Windows,GUI,フォーム,業務,Excel,Word,事務,仕事,ビジネスマン,学生,社員,OL,高校生,中学生,小学生,大学生,主婦,経理,営業,クジラ,クジラ飛行机,日本人,オープンソース,無料,フリー,ダウンロード,教科書,解説,簡単,わかりやすい,やさしい,できる,用語,命令,関数,処理,ツール,アプリ,アプリケーション,バッチ,自動,マクロ,変数,アルゴリズム,親切,丁寧,学ぶ,素早く,公式,バイブル,わからない,できない,難しい,英語,効率,短時間,能率,ハック,文書,データ,書類,資料,html,結果,実績,成績,人気,問題,課題,解決,回答,質問,女子,素人,未経験,プロ,上級,初級,入門,専門

この記事に含まれるtag : サンプル マニュアル 

FC2スレッドテーマ : プログラミング (ジャンル : コンピュータ

(記事編集) http://nadesocha.blog.fc2.com/blog-entry-163.html

2012/12/08 | Comment (0) | Trackback (0) | ホーム | ↑ ページ先頭へ ↑ |

文字数カウンターを作ってみた

   ↑  2012/04/23 (月)  カテゴリー: サンプルプログラム
クジラさんも、このようなツールを利用して、本を書いておられるのかな?

Edt01とはエディタ。Edt01について
 X=10;Y=10;W=50;文字サイズ=10;テキスト=「1」
Lbl01とはラベル。Lbl01について
 X=70;Y=13;文字サイズ=10;テキスト=「文字以上」
Edt02とはエディタ。Edt02について
 X=160;Y=10;W=50;文字サイズ=10;テキスト=「300」
Lbl02とはラベル。Lbl02について
 X=220;Y=13;文字サイズ=10;テキスト=「文字以下」
Lbl03とはラベル。Lbl03について
 X=320;Y=13;文字サイズ=10;テキスト=「現在の文字数:」
Edt03とはエディタ。Edt03について
 X=420;Y=10;W=50;文字サイズ=10;編集=オフ;テキスト=「」
Btn01とはボタン。Btn01について
 X=490;Y=8;W=100;テキスト=「本文をコピー」
 クリックした時は~本文コピー
Mem01とはメモ。Mem01について
 X=10;Y=45;W=600;H=320;文字サイズ=10
 変更した時は~文字カウント

●本文コピー
 クリップボード=Mem01のテキスト。
 「クリップボードにコピーしました。」と言う。

●文字カウント
 String=(Mem01のテキスト)の改行を「」に置換。
 Length=Stringの文字数。
 Min=(Edt01のテキスト)*1
 Max=(Edt02のテキスト)*1
 もしLength  Edt03の背景色=青色。Edt03の文字色=白色。
 違えばもしLength>Maxならば
  Edt03の背景色=赤色。Edt03の文字色=青色。
 違えば
  Edt03の背景色=緑色。Edt03の文字色=黒色。
 Edt03のテキスト=Length


ダウンロードはこちら。文字数カウント

この記事に含まれるtag : サンプル 

FC2スレッドテーマ : プログラミング (ジャンル : コンピュータ

(記事編集) http://nadesocha.blog.fc2.com/blog-entry-143.html

2012/04/23 | Comment (0) | Trackback (0) | ホーム | ↑ ページ先頭へ ↑ |

パスワードの生成ツールを作ってみた

   ↑  2012/04/15 (日)  カテゴリー: サンプルプログラム
 最近、仕事で職員のユーザー登録することが多く、パスワードを決めるのが面倒なので、
簡単なプログラムでランダムな文字列を作成しているのですが、システムごとに
パスワードのルールが異なるために、その都度、プログラムを変更していました。

 そこで、いろんなパターンのパスワードルールに対応できるように、きちんと
プログラムを書いてみました。
 また、「l(エル)」と「1(いち)」を間違えないように、「l(エル)」を使用しない
設定にできるようにもしてみました。

#パスワード生成

Nums=「0123456789」
ABCS=「abcdefghijklmnopqrstuvwxyz」
ABCL=「ABCDEFGHIJKLMNOPQRSTUVWXYZ」
Mark=「!#$%&()*+-.:;<=>?@」
Password=「」
Candidate=「」

母艦のテキスト=「パスワード生成」
母艦の背景色=水色。
Lbl01とはラベル。Lbl01について
 X=340。Y=10。テキスト=「前」
Lbl02とはラベル。Lbl02について
 X=440。Y=10。テキスト=「中」
Lbl03とはラベル。Lbl03について
 X=540。Y=10。テキスト=「後」
Lbl04とはラベル。Lbl04について
 X=280。Y=50。テキスト=「桁数」
Lbl05とはラベル。Lbl05について
 X=10。Y=90。テキスト=「・数字   0123456789」
Lbl06とはラベル。Lbl06について
 X=10。Y=130。テキスト=「・英字(小) abcdefghijklmnopqrstuvwxyz」
Lbl07とはラベル。Lbl07について
 X=10。Y=170。テキスト=「・英字(大) ABCDEFGHIJKLMNOPQRSTUVWXYZ」
Lbl08とはラベル。Lbl08について
 X=10。Y=210。テキスト=「・記号   !#$%&()*+-.:;<=>?@」
Lbl09とはラベル。Lbl09について
 X=10。Y=250。テキスト=「・その他」
Lbl10とはラベル。Lbl10について
 X=10。Y=290。テキスト=「・除外文字」
Lbl11とはラベル。Lbl11について
 X=393。Y=50。テキスト=「+」
Lbl12とはラベル。Lbl12について
 X=493。Y=50。テキスト=「+」
Edt01とはエディタ。Edt01について
 X=95。Y=247。W=200。
Edt02とはエディタ。Edt02について
 X=95。Y=287。W=200。
Iで0から2まで繰り返す。
 Digit[I]をエディタとして作成。
 Digit[I]@X=I*100+323
 Digit[I]@Y=46
 Digit[I]@W=50
 Jで0から5まで繰り返す。
  Chk[I,J]をチェックとして作成。
  Chk[I,J]@X=I*100+340
  Chk[I,J]@Y=J*40+90
  Chk[I,J]@テキスト=「」
Btn01とはボタン。Btn01について
 X=20。Y=330。W=150。H=40。テキスト=「パスワード生成」
 クリックした時は~生成処理
Edt03とはエディタ。Edt03について
 X=190。Y=334。W=250。文字サイズ=18。
 背景色=黄色。テキスト=「********」
Btn02とはボタン。Btn02について
 X=455。Y=330。W=165。H=40。テキスト=「クリップボードへコピー」
 クリックした時は~転写処理

●生成処理
 Password=「」
 Iで0から2まで繰り返す。
  Password=Password&(Iをパスワード計算)。
 Edt03のテキスト=Password

●パスワード計算(Aを)
 乱数初期化。
 TMP=「」
 パスワード桁数=Digit[A]@テキスト
 もしパスワード桁数<1ならば
  「」で戻る。
 Aで候補作成。
 (パスワード桁数)回
  TMP=TMP&(Candidateの((Candidateの文字数)の乱数+1)から1文字抜き出す)
 TMPで戻る。

●候補作成(Aで)
 Candidate=「」
 もしChk[A,0]@値=1ならば
  Candidate=Candidate&Nums
 もしChk[A,1]@値=1ならば
  Candidate=Candidate&ABCS
 もしChk[A,2]@値=1ならば
  Candidate=Candidate&ABCL
 もしChk[A,3]@値=1ならば
  Candidate=Candidate&Mark
 もしChk[A,4]@値=1ならば
  Candidate=Candidate&(Edt01のテキスト)
 もしChk[A,5]@値=1ならば
  #除外文字
  exception=Edt02のテキスト
  rで1から(exceptionの文字数)まで繰り返す。
   replace=exceptionのrから1文字抜き出す。
   Candidate=Candidateのreplaceを「」に置換。

●転写処理
 クリップボード=Edt03のテキスト。
 「クリップボードにコピーしました。」と言う。

この記事に含まれるtag : サンプル 

FC2スレッドテーマ : プログラミング (ジャンル : コンピュータ

(記事編集) http://nadesocha.blog.fc2.com/blog-entry-141.html

2012/04/15 | Comment (0) | Trackback (0) | ホーム | ↑ ページ先頭へ ↑ |
申し訳ありません。 お探しの記事は現在、この ユーザーtag (Keyword) を設定していない可能性があります。 右の検索BOXで 再度用語を短めに入力していただくと記事が見つかる場合があります。

上記広告は1ヶ月以上更新のないブログに表示されています。新しい記事を書くことで広告を消せます。